Support forum for ASP.NET Zero (https://aspnetzero.com/).
By cengiz
#31508 Hi,

When I run the project on localhost, which is a new project that I have just created, the following text is only displayed on the screen after successful login and the user interface (menus, panellas, etc.) is not shown.

{"result":null,"targetUrl":"/Account/ResetPassword?UserId=1&ResetCode=DA80A900F1&ReturnUrl=%2FApp","success":true,"error":null,"unAuthorizedRequest":false,"__abp":true}

Type: AspNetZeroCore
Version: v5.6.2
Framework : .Net Core 2.1


Debbug screenshot and text below Login screen;

Debbug Screen:

Image

Debbug Error Text:
SCRIPT5007: SCRIPT5007: Unable to get property 'unspecifiedClockProvider' of undefined or null reference
GetScripts (1154,5)
SCRIPT5009: SCRIPT5009: 'jQuery' is not defined
common-scripts.js (2,2)
SCRIPT445: SCRIPT445: Object doesn't support this action
Default.js (3,5)
SCRIPT5009: SCRIPT5009: 'jQuery' is not defined
Login (180,9)
By cengiz
#31526 Hi,

Thanks for reply;

When I run the command, the current log records occur.


13 verbose stack at EventEmitter.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\index.js:304:16)
13 verbose stack at EventEmitter.emit (events.js:182:13)
13 verbose stack at ChildProcess.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
13 verbose stack at ChildProcess.emit (events.js:182:13)
13 verbose stack at maybeClose (internal/child_process.js:962:16)
13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:249:5)
14 verbose pkgid abpzerotemplate@5.0.0
15 verbose cwd D:\Resources\AspNetZero\core\Oes
16 verbose Windows_NT 10.0.17134
17 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "run" "create-bundles"
18 verbose node v10.8.0
19 verbose npm v6.2.0
20 error code ELIFECYCLE
21 error errno 1
22 error abpzerotemplate@5.0.0 create-bundles: `gulp copy:node_modules && npm run bundle-clean:bundle`
22 error Exit status 1
23 error Failed at the abpzerotemplate@5.0.0 create-bundles script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 1, true ]



maliming wrote:I guess you forgot to execute: "npm run create-bundles"

https://aspnetzero.com/Documents/Gettin ... he-project
By cengiz
#31547 Hi,
It would be useful to look first at the beginning guide.

https://aspnetzero.com/Documents/Getting-Started-Core

I followed the steps below to solve the problem;

Make sure that the requirements are set up on your system.
https://aspnetzero.com/Documents/Gettin ... quirements


After you check that the requirements are installed,
Go to the ../src\Oes.Web.Mvc folder and type cmd.exe in the address bar,
run the following line on the incoming command line display;

Code: Select allnpm run create-bundles


If you complete this operation without getting an error, the error goes away.

Thank you, good work.